import re
regex = re.compile(r"^\s?(\+\s?7|8)\s?[\s-]?\(?\s?\d{3,4}\s?\)?(([-\s]){0,3}(\d{1,3})){0,}$", flags=re.MULTILINE)
test_str = ("84951234567\n"
"+74951234567\n"
"8-495-1-234-567\n"
" 8 (8122) 56-56-56\n"
"8-911-1234567\n"
"8 (911) 12 345 67\n"
"8-911 12 345 67\n"
"8 (911) - 123 - 45 - 67\n"
"+ 7 999 123 4567\n"
"8 ( 999 ) 1234567\n"
"8 999 123 4567\n\n"
"// выше - правильные, ниже - неправильные:\n\n"
"02\n"
"84951234567 позвать люсю\n"
"849512345\n"
"849512345678\n"
"8 (409) 123-123-123\n"
"7900123467\n"
"5005005001\n"
"8888-8888-88\n"
"84951a234567\n"
"8495123456a\n"
"+1 234 5678901\n"
"+8 234 5678901\n"
"7 234 5678901\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")