use strict;
my $str = '8-4-1-2-5
8 (8122) 56-56-56
8-911-1234567
8-495-1-234-zzz
8-911 12 345 67
8 (409) 123-123-123
1-2-3-4-5-6-8-7-6';
my $regex = qr/(([0-9.]+)\-)+([0-9]+)/up;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";