re = /^(([1-9]|0[1-9]|1[0-2])\/([1-9]|0[1-9]|1\d|2\d|3[01])\/(19|20)\d{2}|[nN]\/[aA])$/m
str = '01/05/2015
1/5/2015
01/5/2015
1/05/2015
n/a
n/A
N/A
N/a
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end