using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((((?<!\w)[A-Z,a-z]:)|(\.{1,2}\\))([^\b%\/\|:\n\""]*))|(""\2([^%\/\|:\n\""]*)"")|((?<!\w)(\.{1,2})?(?<!\/)(\/((\\\b)|[^ \b%\|:\n\""\\\/])+)+\/?)";
string input = @"lines = [
# URLs
""https://www.google.com"",
""www.google.com"",
""www.google.com www.example.com"",
""([nested parens](https://www.example.com))"",
# Paths
""/foo/bar"",
""/foo/bar.txt"",
""../foo/bar/"",
""../../foo/bar/"",
""./foo/bar/"",
""./foo/bar.txt"",
r""\foo\bar.txt"",
r""C:\\foo\\bar.txt"",
""C:/foo/bar.txt"",
""./"",
""~/foo/bar.txt"",
# Mixed
""https://www.google.com ./foo/bar.txt"",
""[markdown file path](./foo/bar.txt)"",
""Lorem ipsum ./foo_bar/baz.txt Lorem ipsum"",
""[markdown directory](./foo/bar/)"",
"">>> with open('./foo/bar/') as f: "",
""~~[strikeout]('./foobar/')~~"",
# Remaining Issues
""([nested parens](./foo/bar/))"",
""/foo's/bar/"",
""./newlines\n"",
""https://trends.google.com/trends/1"",
""1/2/3"",
""1//2"",
""(./)"",
]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}