$re = '/([0-9]{1,3}\.?){4}/';
$str = '192.168.1.1
12345555555';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);