$re = '/(?={each\ \$nestedArr}) ({each\ \$\w+} (?: [^{] | {(?!\/?each) | (?1) )* {\/each})/x';
$str = '<ul>
{each $nestedArr}
<li>{$group}</li>
<ul>
{each $user}
<li>{$name}</li>
{/each}
</ul>
{/each}
</ul>';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);