$re = '/({%)\s*(tag)((?:(?!{%).)*?)(?:\s*(?:(%})((?:(?:(?:(?!{%).)*?)|(?R))*)(?:({%)\s*(end\2)\s*(%}))))/s';
$str = '{% tag xyz %}
{% tag abc %}
{% endtag %}
{
{% endtag %}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);