use strict;
my $str = 'test
test2 ';
my $regex = qr/\s\s*$/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";