re = /^(\+|-)?(((\d{1,3}[, ])(\d{3}[ ,])*\d{3})|\d+)( ?[\.,] ?(\d{3}[, ])*\d+)?$/m
str = '1.12,4.64
123,233,232 323,233 233.233,233333'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end