package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d`)
var str = `1
2
3
4
5
6
7
8
9
10
11
0
a`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}