re = /^(?!.*\.-.*$|.*-\..*$)([a-zA-Z0-9._-]+)([a-zA-Z0-9]@[a-zA-Z0-9])([a-zA-Z0-9.-]+)([a-zA-Z0-9]\.[a-zA-Z]{2,3})$/im
str = 'chris@data.services.com
chris@data-services.com
chris@data.-services.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end