import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\{(?<Time>\\d{2}:\\d{2}:\\d{2})\\} System:\"(?<SystemName>[^\"]+)\" StarPos:\\((?<StarPos_X>[^,]+),(?<StarPos_Y>[^,]+),(?<StarPos_Z>[^)]+)\\)ly( Body:(?<Body>\\d+) RelPos:\\((?<RelPos>[^)]+)\\)km)?(\\s+(?<TravelMode>\\w+))?";
final String string = "// Verbose Netlog\n"
+ "{09:41:22} System:\"Iorant ND-K d8-1\" StarPos:(-1085.656,-20.906,64947.563)ly Body:0 RelPos:(-4.31614e+08,1.01307e+07,3.68466e+07)km NormalFlight\n"
+ "// Non-verbose netlog\n"
+ "{21:14:06} System:\"Myeia Thaa WD-K d8-0\" StarPos:(-1655.375,-22.625,64936.594)ly NormalFlight\n"
+ "// Entries with weird characters\n"
+ "{21:14:06} System:\"Sagittarius A*\" StarPos:(0.375,30.625,32000.594)ly NormalFlight\n"
+ "{21:14:06} System:\"Foo Bar 123 !£$%*[]{}-=_+*\" StarPos:(0.375,30.625,32000.594)ly NormalFlight";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}