import re
regex = re.compile(r"(?<=>)([\w\s]+)(?=</)", flags=re.MULTILINE)
test_str = ("<table>\n"
"<tr><td>Cell 1</td><td>Cell 2</td><td>Cell 3</td></tr>\n"
"<tr><td>Cell 4</td><td>Cell 5</td><td>Cell 6</td></tr>\n"
"</table>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")