# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^hotma.*(om|cm|co|et)$|^hotmail\.com[^\.].*$|^hotmail$|^h(to)?mail\.com"
test_str = ("SQL Expression\n\n\n"
"hotmail.es\n"
"hotmail.co.kr\n"
"hotmail.co.uk\n"
"hotmail.com.tw\n\n\n"
"hotmail.com\n"
"hotmail\n"
"hotmailcom\n"
"htomail.com\n"
"hmail.com\n"
"hotmai.com\n"
"hotmail.cm\n"
"hotmail.net\n"
"hotmailc.om\n"
"hotmaol.com\n"
"homail.com\n"
"hotmail.co\n"
"hotmail.comahmedshakirny\n\n\n"
"hotmail.com\n"
"hotmail\n"
"hotmailcom\n"
"htomail.com\n"
"hotmail.es\n"
"hotmail.co.kr\n"
"hotmail.co.uk\n"
"hmail.com\n"
"hotmai.com\n"
"hotmail.cm\n"
"hotmail.net\n"
"hotmailc.om\n"
"hotmaol.com\n"
"homail.com\n"
"hotmail.co\n"
"hotmail.comahmedshakirny\n"
"hotmail.comc\n"
"hotmail.comi\n"
"hotmail.om\n"
"hoymail.com\n"
"hitmail.com\n"
"hjotmail.com\n"
"hormail.com\n"
"hotgmail.com\n"
"hotmaii.com\n"
"hotmail..com\n"
"hotmail..comn\n"
"hotmail.com.lowercaseletter\n"
"hotmail.com.tw\n"
"hotmail.comgeorge4nyy\n"
"hotmail.comjehan.nizam09\n"
"hotmail.commn\n"
"hotmail.comn\n"
"hotmail.comorgmail.com\n"
"hotmail.comorvince1812\n"
"hotmail.con\n"
"hotmail.conm\n"
"hotmail.corp\n"
"hotmail.vom\n"
"hotmail.xom\n"
"hotmain.com\n"
"hotmaiul.com\n"
"hotmmail.com\n"
"hpotmail.com\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.