package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^\w\s\.,\!]+)`)
var str = `ҧҧҧҧҧҧ Helҧҧҧlo, Woҧrldҧ!`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}