package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([a-z A-Z 0-9 À-ÿ]*).(?i)(\bpb\b|\bpbi\b)`)
var str = `main.pbp`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}