$re = '/(noun|adj|adv)((?!\1).)+</m';
$str = 'noun abc <html>
adj def adj <html>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);