import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\".*?(hotelscombined\\.com).*?\\\"";
final String string = "<p>We had original plans to stop in <strong>Savannah</strong> for a night, but it was so close to Charleston that we decided to just top there for a few hours for lunch and a look and then drive the other few hours to Jacksonville.</p> <p>We started fairly late in the morning as we took the kids to a playground to expend their energy first thing in the morning. After half an hour of so of playing pirates we all jumped into the car to Savannah.</p> <p>In Savannah <strong>we ate at the coolest Pirate House restaurant</strong> that was built in the 1700�s. We posted a postcard and then bounced back into our mini van for the drive to <strong>Jacksonville</strong>.</p> <p>Drive was pretty uneventful with one amazing bridge and crossing over the border into Florida was exciting too.</p> <p>We realized we�d <a title=\"Where to stay when you are road tripping East Coast USA\" href=\"/\">booked a hotel at the actual airport</a>, but it was super cheap and had nearby food so we ate, then put the kids to bed. <em><a href=\"http://www.hotelscombined.com/Hotel/Jacksonville_Airport_Hotel.htm\" target=\"_blank\">For the latest prices at the Hilton click here. </a></em></p> <p><img style=\"display: block; margin-left: auto; margin-right: auto;\" src=\"/files/\" alt=\"DSC07623.jpg\" width=\"700\" height=\"465\" /></p> <p> </p>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}