re = /[-a-zA-Z0-9@:%._\+~#=]{2,256}\.[a-z]{2,6}\b[-a-zA-Z0-9@:%_\+.~#?&\/\/=]*/i
str = 'www.m.m.mm'
# Print the match result
str.match(re) do |match|
puts match.to_s
end