re = /^(?:(?:http[s]?|ftp):\/)?\/?(?:[^:\/\s]+?\.)*([^:\/\s]+\.[^:\/\s]+)/
str = 'http://mail.yandex.ru/zaaa
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end