$re = '/[^a-zA-Z]+/m';
$str = 'Olympia, WA: SLP Full or Part Time';
$subst = "-";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;