re = /\[0d0a\]|\[0d0a02\]|\[0d0a02\]/m
str = '[01]ABC0007[0d0a]BB BABLOXC[0d0a]067989 PLPXBNS[0d0a02]BBR OIC002 L5U0/P AMD KAP 041800 T1200AND 2+00[0d0a0b03]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end