$re = '/\sNew User:\s([^_]+_user)\sfunction:\s(auditor|auditor2)\s/s';
$str = 'blablabla bla bla blabla New User: John_user function: auditor blablablablabl bla blab New User: Do_user function: auditor2 blablabl blablb...';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);