# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\"([^\"]+)\""
test_str = "<WebApicall id=\"4\" time=\"2013-10-05; 22:44:18\" timeStamp=\"|18|44|22|5|9|113|6|277|0|\" tick=\"11589293\" file=\"self\" bdlLine=\"61\" type=\"url\" url=\"http://www.google.com/\"> WebUrl </WebApicall>"
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.