$re = '/^([^.]+(?:[^.]*\.){2})([^.].*)/m';
$str = '1.01.1
1.01.2
1.01.3
1.02.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);