package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`@(.*?)[\s]`)
var str = `این یک @پیا.م تست است`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}