$re = '/^\d+(\.\d{0,2})?$/';
$str = '
3456
897.8989898
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);