package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\s+|\s+$`)
var str = ` z
z
z
z
zzz zz zzz `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}