import Foundation
let pattern = #"([A-Za-z]+(?:\s|,|\(|\)|'|[A-Za-z\u00E9])+)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
Canada 1 202,080 1 265,523 9,984,670 20.2 26.6
Indonesia 2 54,716 4 95,181 1,811,569 30.2 52.5
Greenland[Note 4] — 44,087 2,166,086 20.4
Russia 3 37,653 3 110,310 16,377,742 2.30 6.74
Philippines 4 36,289 8 33,900 298,170 122 114
Japan 5 29,751 12 29,020 364,485 81.6 79.6
Australia 6 25,760 6 66,530 7,682,300 3.35 8.66
Norway 7 25,148[Note 5] 7 53,199 304,282 82.6 175
United States 8 19,924 2 133,312 9,161,966 2.17 14.6
Antarctica — 17,968 14,000,000 1.28
New Zealand 9 15,134 17 17,209 267,710[5] 56.5 64.3
China 10 14,500 11 30,017 9,569,901 1.52 3.14
Greece 11 13,676 19 15,147 131,957 104 115
United Kingdom 12 12,429 16 19,717 241,930 51.4 81.5
Mexico 13 9,330 14 23,761 1,943,945 4.80 12.2
Italy 14 7,600 28 9,226 294,140 25.8 31.4
Brazil 15 7,491 9 33,379 8,459,417 0.886 3.95
Denmark 16 7,314 44 5,316 42,434 172 125
Turkey 17 7,200 31 8,140 783,562 9.19 10.4
India 18 7,000 18 17,181 2,973,193 2.35 5.78
Chile 19 6,435 5 78,563 743,812 8.65 106
Croatia 20 6,268[6] 42 5,664 55,974 112 101
Micronesia, Federated States of 21 6,112 92 1,295 702 8,710 1,840
Solomon Islands 22 5,313 26 9,880 27,986 190 353
Papua New Guinea 23 5,152 15 20,197 452,860 11.4 44.6
Argentina 24 4,989 30 8,397 2,736,690 1.82 3.07
Iceland 25 4,970 29 8,506 100,250 49.6 84.8
Spain[Note 6] 26 4,964 34 7,268 498,980 9.95 14.6
France 27 4,853 33 7,330 640,427 7.58 11.4
Madagascar 28 4,828 25 9,935 581,540 8.30 17.1
Malaysia 29 4,675 27 9,323 328,657 14.2 28.4
Estonia 30 3,794 61 2,956 42,388 89.5 69.7
Cuba 31 3,735 21 14,519 109,820 34.0 132
Svalbard — 3,587 62,045 57.8
Bahamas, The 32 3,542 24 11,238 10,010 354 1,120
Vietnam 33 3,444[Note 7] 23 11,409 310,070 11.1 36.8
Thailand 34 3,219 35 7,066 510,890 6.30 13.8
Sweden 35 3,218 13 26,384 410,335 7.84 64.3
Colombia 36 3,208 41 5,875 1,038,700 3.09 5.66
Coral Sea Islands — 3,095 <3 >1,000,000
Somalia 37 3,333 50 3,898 627,337 5.31 6.21
French Southern and Antarctic Lands — 2,948.4[Note 8] 7,667.6 385
Venezuela 38 2,800 37 6,762 882,050 3.17 7.67
South Africa 39 2,798 51 3,751 1,214,470 2.30 3.09
Ukraine 40 2,782 45 4,953 579,330 4.80 8.55
Saudi Arabia 41 2,640 32 7,572 2,149,690 1.23 3.52
Vanuatu 42 2,528 59 3,132 12,189 207 257
French Polynesia — 2,525 — 5,830 3,827 660 1,520
Korea, North 43 2,495 49 4,009 120,408 20.7 33.3
Panama 44 2,490 43 5,637 74,340 33.5 75.8
Mozambique 45 2,470 36 6,942 786,380 3.14 8.83
Egypt 46 2,450 39 5,898 995,450 2.46 5.92
Iran 47 2,440[Note 9] 40 5,891 1,531,595 1.59 3.85
Peru 48 2,414 55 3,362 1,279,996 1.89 2.63
Korea, South 49 2,413 22 12,478 96,920 24.9 129
Germany 50 2,389 52 3,624 348,672 6.85 10.4
New Caledonia — 2,254 — 3,624 18,275 123 198
Ecuador 51 2,237 47 4,597 276,841 8.08 16.6
Eritrea 52 2,234[6] 54 3,446 101,000 22.1 34.1
Oman 53 2,092 65 2,810 309,500 6.76 9.08
Burma 54 1,930 20 14,708 653,508 2.95 22.5
Yemen 55 1,906 58 3,149 527,968 3.61 5.96
Morocco 56 1,835 73 2,009 446,300 4.11 4.50
Portugal 57 1,793 63 2,830 91,470 19.6 30.9
Haiti 58 1,771 77 1,977 27,560 64.3 71.7
Libya 59 1,770 71 2,025 1,759,540 1.01 1.15
Angola 60 1,600 67 2,252 1,246,700 1.28 1.81
Namibia 61 1,572 84 1,754 823,290 1.91 2.13
Taiwan 62 1,566.3 74 2,007 32,260 48.6 62.2
Palau 63 1,519 459 3,310
Northern Mariana Islands — 1,482 464 3,190
Ireland 64 1,448 38 6,437 68,883 21.0 93.4
Tanzania 65 1,424 53 3,461 885,800 1.61 3.91
Sri Lanka 66 1,340 64 2,825 64,630 20.7 43.7
United Arab Emirates 67 1,318 62 2,871 83,600 15.8 34.3
Costa Rica 68 1,290 70 2,069 51,060 25.3 40.5
Dominican Republic 69 1,288 88 1,612 48,320 26.7 33.4
Falkland Islands — 1,288 12,173 106
Finland 70 1,250 10 31,119 303,815 4.11 102
Tunisia 71 1,148 79 1,927 155,360 7.39 12.4
Kiribati 72 1,143 78 1,961 811 1,410 2,420
Fiji 73 1,129 46 4,638 18,274 61.8 254
Faroe Islands — 1,117 1,393 802
Western Sahara — 1,110 266,000 4.17
Pakistan 74 1,046 66 2,599 881,912 1.19 2.95
Jamaica 75 1,022 102 895 10,831 94.4 82.6
Algeria 76 998 90 1,557 2,381,741 0.419 0.654
Cape Verde 77 965 97 1,121 4,033 239 278
Spratly Islands — 926 <5 >200,000
Nicaragua 78 910 80 1,915 119,990 7.58 16.0
Gabon 79 885 72 2,019 257,667 3.43 7.84
Nigeria 80 853 60 3,122 910,768 0.937 3.43
Sudan 80 853 68 2,245 1,861,484[5] 0.458 1.21
Honduras 82 832[Note 10] 82 1,878 111,890 7.44 16.8
Mauritania 83 754 94 1,268 1,030,700 0.732 1.23
Hong Kong — 733 — 955 1,054 695 906
Timor-Leste 84 706 14,874 47.5
British Indian Ocean Territory — 698 60 11,600
Uruguay 85 660 98 1,096 175,015 3.77 6.26
Cyprus 86 648 112 671 9,241 70.1 72.6
Maldives 87 644 75 2,002 298 2,160 6,720
Bangladesh 88 580 56 3,306 130,168 4.46 25.4
Liberia 89 579 104 842 96,320 6.01 8.74
Qatar 90 563 100 909 11,586 48.6 78.5
Ghana 91 539 106 758 227,533 2.37 3.33
Kenya 92 536 89 1,586 569,140 0.942 2.79
Senegal 93 531 91 1,327 192,530 2.76 6.89
Paracel Islands — 518 7.75 66,800
Côte d'Ivoire 94 515 105 797 318,003 1.62 2.51
Puerto Rico — 501 — 1,094 8,870 56.5 123
Kuwait 95 499 107 756 17,818 28.0 42.4
Latvia 96 498 116 566 62,249 8.00 9.09
Seychelles 97 491 109 747 455 1,080 1,640
Guyana 98 459 95 1,154 196,849 2.33 5.86
Netherlands 99 451[Note 11] 81 1,914 33,893 13.3 56.5
Cambodia 100 443 96 1,127 176,515 2.51 6.38
Poland 101 440 99 1,032 312,679 1.41 3.30
Tonga 102 419 101 909 717 584 1,270
Samoa 103 403 120 463 2,821 143 164
Cameroon 104 402 83 1,799 469,440 0.856 3.83
Sierra Leone 104 402 86 1,677 71,620 5.61 23.4
Guatemala 106 400 122 445 107,159 3.73 4.15
Turks and Caicos Islands — 389 948 410
Belize 107 386 76 1,996 22,806 16.9 87.5
Suriname 107 386 114 620 156,000 2.47 3.97
Marshall Islands 109 370.4 69 2,106 181 2,050 11,600
Curacao — 364 444 820
Albania 110 362 113 649 27,398 13.2 23.7
Trinidad and Tobago 110 362 110 704 5,128 70.6 137
Bulgaria 112 354 121 457 108,489 3.26 4.21
Guinea-Bissau 113 350 57 3,176 28,120 12.4 113
Comoros 114 340 119 469 2,235 152 210
Guinea 115 320 87 1,615 245,717 1.30 6.57
Djibouti 116 314 123 443 23,180 13.5 19.1
Georgia 117 310 124 376 69,700 4.45 5.39
El Salvador 118 307 108 756 20,721 14.8 36.5
Equatorial Guinea 119 296 115 603 28,051 10.6 21.5
Montenegro 120 293.5 13,452 21.8
Israel 121 273 136 205 20,330 13.4 10.1
Lebanon 122 225 125 294 10,230 22.0 28.7
Romania 122 225 111 696 229,891 0.979 3.03
São Tomé and Príncipe 124 209 128 269 964 217 279
Malta 125 252.81 137 198 316 800 627
Singapore 126 193 129 268 687 281 390
Syria 126 193 134 212 183,630 1.05 1.15
U.S. Virgin Islands — 188 — 390 346 543 1,130
Mauritius 128 177 118 496 2,030 87.2 244
Congo, Republic of the 129 169 135 205 341,500 0.495 0.600
Bahrain 130 161 132 255 760 212 336
Brunei 130 161 127 269 5,265 30.6 51.1
Cayman Islands — 160 264 606
Isle of Man — 160 572 280
Saint Lucia 132 158 139 166 606 261 274
Antigua and Barbuda 133 153 126 289 442.6 346 653
Dominica 134 148 141 152 751 197 202
Christmas Island — 138.9 135 1,030
Saint Kitts and Nevis 135 135 261 517
Wallis and Futuna — 129 142 908
Guam — 125.5 544 231
Jan Mayen — 124.1 377 329
Benin 136 121 140 153 110,622 1.09 1.38
Grenada 136 121 133 252 344 352 733
Cook Islands 138 120 236 508
Saint Pierre and Miquelon — 120 242 496
American Samoa — 116 199 583
Bermuda — 103 — 180 54 1,910 3,330
Heard Island and McDonald Islands — 101.9 412 247
Tokelau — 101 12 8,420
Saint Helena, Ascension and Tristan da Cunha — 100[Note 12] 308 325
Barbados 139 97 143 97 430 226 226
Lithuania 140 90 131 258 62,680 1.44 4.12
United States Pacific Island Wildlife Refuges — 85.7 22.41 3,820
Saint Vincent and the Grenadines 141 84 130 264 389 216 679
Akrotiri and Dhekelia — 83.8 253.8[5] 330
British Virgin Islands — 80 151 530
Gambia 142 80 117 503 10,000 8.00 50.3
Ashmore and Cartier Islands — 74.1 5 14,800
Jersey — 70 116 603
Aruba — 68.5 — 107 180 381 594
Belgium 143 66.5 144 76 30,278 2.20 2.51
Niue 144 64 260 246
Anguilla — 61 91 670
Saint Martin — 58.9[Note 13] 54.4 1,080
Iraq 145 58 142 105 437,367 0.133 0.240
Togo 146 56 145 53 54,385 1.03 0.975
Pitcairn Islands — 51 47 1,090
Guernsey — 50 78 641
Slovenia 147 46.6 146 41 20,151 2.31 2.03
Macau — 41 — 36 28.2 1,450 1,280
Gaza Strip — 40 360 111
Montserrat — 40 102 392
Congo, Democratic Republic of the 148 37 138 177 2,267,048 0.0163 0.0781
Norfolk Island — 32 36 889
Nauru 149 30 21 1,430
Bouvet Island — 29.6 49 604
Cocos (Keeling) Islands — 26 14 1,860
Jordan 150 26 147 27 88,802 0.293 0.304
Tuvalu 151 24 26 923
Bosnia and Herzegovina 152 20 148 23 51,187 0.391 0.449
Wake Island — 19.3 6.5 2,970
Gibraltar — 12 6.5 1,850
Clipperton Island — 11.1 6 1,850
Navassa Island — 8 5.4 1,480
Monaco 153 4.1 2 2,050
Saint Barthelemy — NA NA 21
Sint Maarten — NA[Note 14] 34 0.0147
South Georgia and the South Sandwich Islands — NA 3,903 0.000128
Kazakhstan 154 0[Note 15] 48 4,528 2,699,700 0 1.68
Turkmenistan 154 0[Note 16] 93 1,289 469,930 0 2.74
Azerbaijan 154 0[Note 17] 103 871 82,629 0 10.5
Uzbekistan 154 0[Note 18] 85 1,707 425,400 0 4.01
Afghanistan 154 0 149 0 652,230 0 0
Andorra 154 0 468 0
Armenia 154 0 149 0 28,203 0 0
Austria 154 0 149 0 82,445 0 0
Belarus 154 0 149 0 202,900 0 0
Bhutan 154 0 149 0 38,394 0 0
Bolivia 154 0 149 0 1,083,301 0 0
Botswana 154 0 149 0 566,730 0 0
Burkina Faso 154 0 149 0 273,800 0 0
Burundi 154 0 149 0 25,680 0 0
Central African Republic 154 0 149 0 622,984 0 0
Chad 154 0 149 0 1,259,200 0 0
Czech Republic 154 0 149 0 77,247 0 0
Ethiopia 154 0 149 0 1,000,000 0 0
Hungary 154 0 149 0 89,608 0 0
Kyrgyzstan 154 0 149 0 191,801 0 0
Laos 154 0 149 0 230,800 0 0
Lesotho 154 0 149 0 30,355 0 0
Liechtenstein 154 0 160 0
Luxembourg 154 0 149 0 2,586 0 0
Macedonia, Republic of 154 0 149 0 25,433 0 0
Malawi 154 0 149 0 94,080 0 0
Mali 154 0 149 0 1,220,190 0 0
Moldova 154 0 149 0 32,891 0 0
Mongolia 154 0 149 0 1,553,556 0 0
Nepal 154 0 149 0 143,351 0 0
Niger 154 0 149 0 1,266,700 0 0
Paraguay 154 0 149 0 397,302 0 0
Rwanda 154 0 149 0 24,668 0 0
San Marino 154 0 61 0
Serbia 154 0 88,361 0
Slovakia 154 0 149 0 48,105 0 0
South Sudan 154 0 644,329[5] 0
Swaziland 154 0 149 0 17,204 0 0
Switzerland 154 0 149 0 39,997 0 0
Tajikistan 154 0 149 0 141,510 0 0
Uganda 154 0 149 0 197,100 0 0
Vatican City 154 0 0.44 0
West Bank — 0 5,640 0
Zambia 154 0 149 0 743,398 0 0
Zimbabwe 154 0 149 0 386,847 0 0
French Guiana — 763
Guadeloupe — 581
Martinique — 369
Netherlands Antilles — 361
Réunion
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)