$re = '/\b(?!if\b)\p{Ll}+\b/';
$str = 'I am trying to learn to handle Regex Expressions and got some exercises but no solutions to it. One Question is: all lower-case words except \'if\'.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);