$re = '/-([^-]+)$/m';
$str = 'TEST-QWE-1
TEST/QWE-22
TEST@QWE-3
TEST-QWE-ASD-4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);