#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z]:\\(((?![<>:"\/\\|?*]).)+((?<![ .])\\)?)*$"
Local $sString = "C" & @CRLF & _
"C:" & @CRLF & _
"C:/" & @CRLF & _
"C://" & @CRLF & _
"C:\" & @CRLF & _
"C:\\" & @CRLF & _
"C:\Documents\Newsletters\Summer2018.pdf" & @CRLF & _
"\Program Files\Custom Utilities\StringFinder.exe" & @CRLF & _
"2018\January.xlsx" & @CRLF & _
"..\Publications\TravelBrochure.pdf" & @CRLF & _
"C:\Projects\apilibrary\apilibrary.sln" & @CRLF & _
"C:Projects\apilibrary\apilibrary.sln" & @CRLF & _
"\\system07\C$\" & @CRLF & _
"\\Server2\Share\Test\Foo.txt" & @CRLF & _
"\\.\C:\Test\Foo.txt" & @CRLF & _
"\\?\C:\Test\Foo.txt" & @CRLF & _
"C:\utilities\filecompare\" & @CRLF & _
"c:\utilities\filecompare\" & @CRLF & _
"\\Server\Share" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")