import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\()?\\d{3}(?(1)\\)|-)\\d{3}-\\d{4}";
final String string = "123-456-7890\n"
+ "(123)456-7890\n"
+ "123 456-7890\n"
+ "(123-456-7890\n"
+ "(123)-456-7890\n"
+ "1234567890\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}