import re
regex = re.compile(r",(?=\{\"TimePeriod\":)")
test_str = "{\"TimePeriod\": {\"Start\": \"2017-03-01\", \"End\": \"2017-04-01\"}, \"Total\": {\"UnblendedCost\": {\"Amount\": \"2942.25119998\", \"Unit\": \"USD\"}, \"UsageQuantity\": {\"Amount\": \"20835\", \"Unit\": \"Hrs\"}}, \"Groups\": [], \"Estimated\": false},{\"TimePeriod\": {\"Start\": \"2017-04-01\", \"End\": \"2017-05-01\"}, \"Total\": {\"UnblendedCost\": {\"Amount\": \"2982.62609983\", \"Unit\": \"USD\"}, \"UsageQuantity\": {\"Amount\": \"21049\", \"Unit\": \"Hrs\"}}, \"Groups\": [], \"Estimated\": false},{\"TimePeriod\": {\"Start\": \"2017-05-01\", \"End\": \"2017-06-01\"}, \"Total\": {\"UnblendedCost\": {\"Amount\": \"1399.04829988\", \"Unit\": \"USD\"}, \"UsageQuantity\": {\"Amount\": \"23010\", \"Unit\": \"Hrs\"}}, \"Groups\": [], \"Estimated\": false},{\"TimePeriod\": {\"Start\": \"2017-06-01\", \"End\": \"2017-07-01\"}, \"Total\": {\"UnblendedCost\": {\"Amount\": \"962.47549987\", \"Unit\": \"USD\"}, \"UsageQuantity\": {\"Amount\": \"20049\", \"Unit\": \"Hrs\"}}, \"Groups\": [], \"Estimated\": false}"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")