import re
regex = re.compile(r"^((\(\+{0,2}[0-9]{1,2}\)|\+{0,2}[0-9]{0,2})?([0-9 ]+)?)$", flags=re.MULTILINE)
test_str = ("508 736 756\n"
"505050505\n"
"+48 505 505 505\n"
"(+48) 505 505 505\n"
"++48 505 505 505\n"
"(++48) 505 505 505\n"
"(23)692 36 99\n"
"23 692 36 99\n"
"() 692 36 99\n"
"(2) 692 36 99\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")