# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\s*\+\s*7|\s*8)([-\s()]*[\d+][-\s()]*){10}$"
test_str = ("84951234567\n"
"+74951234567\n"
"8-495-1-234-567\n"
" 8 (8122) 56-56-56\n"
"8-911-1234567\n"
"8 (911) 12 345 67\n"
"8-911 12 345 67\n"
"8 (911) - 123 - 45 - 67\n"
"+ 7 999 123 4567\n"
"8 ( 999 ) 1234567\n"
"8 999 123 4567\n\n"
"// выше - правильные, ниже - неправильные:\n\n"
"02\n"
"84951234567 позвать люсю\n"
"849512345\n"
"849512345678\n"
"8 (409) 123-123-123\n"
"7900123467\n"
"5005005001\n"
"8888-8888-88\n"
"84951a234567\n"
"8495123456a\n"
"+1 234 5678901\n"
"+8 234 5678901\n"
"7 234 5678901")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.