import Foundation
let pattern = #"[^0-9]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
02-19 12:39:15.788 26903-27412/br.com.iuapp.iuapp D/JOBS: added job id: 2 class: ManageLocalContactsJob priority: 1 delay: 0 group : null persistent: true requires network: true
02-19 12:39:15.788 26903-27412/br.com.iuapp.iuapp D/ManageLocalContactsJob: JOBADDED
02-19 12:39:15.837 26903-27415/br.com.iuapp.iuapp D/JOBS: running job ManageLocalContactsJob
02-19 12:39:16.073 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 18983CONTATO: (IT) Mauricio TELEFONE ORIGINAL: 0411178396138 TELEFONE LIMPO: 1178396138
02-19 12:39:16.156 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 21164CONTATO: +55 31 2138 8236 TELEFONE ORIGINAL: +553121388236 TELEFONE LIMPO: 3121388236
02-19 12:39:16.223 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 202CONTATO: +5511943692511 TELEFONE ORIGINAL: +5511943692511 TELEFONE LIMPO: 11943692511
02-19 12:39:16.363 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 199CONTATO: +5511982836177 TELEFONE ORIGINAL: +5511982836177 TELEFONE LIMPO: 11982836177
02-19 12:39:16.427 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 227CONTATO: +5511999172608 TELEFONE ORIGINAL: +5511999172608 TELEFONE LIMPO: 11999172608
02-19 12:39:16.517 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 5181CONTATO: AJ Vicente TELEFONE ORIGINAL: 01123062621 TELEFONE LIMPO: 1123062621
02-19 12:39:16.605 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 5180CONTATO: AJ Vicente TELEFONE ORIGINAL: 011983317641 TELEFONE LIMPO: 11983317641
02-19 12:39:16.703 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 12731CONTATO: ANTONIO JOSE VICENTE TELEFONE ORIGINAL: 551123062621 TELEFONE LIMPO: 1123062621
02-19 12:39:16.774 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 12732CONTATO: ANTONIO JOSE VICENTE TELEFONE ORIGINAL: 5511983317641 TELEFONE LIMPO: 11983317641
02-19 12:39:16.812 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 11615CONTATO: ARNALDO NASHIRO TELEFONE ORIGINAL: 551131776200 TELEFONE LIMPO: 1131776200
02-19 12:39:16.885 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 11616CONTATO: ARNALDO NASHIRO TELEFONE ORIGINAL: 551131776243 TELEFONE LIMPO: 1131776243
02-19 12:39:16.951 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 14980CONTATO: Abel Reis TELEFONE ORIGINAL: 01137593600 TELEFONE LIMPO: 1137593600
02-19 12:39:17.016 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 12914CONTATO: Adalberto Vianna TELEFONE ORIGINAL: +5511992338663 TELEFONE LIMPO: 11992338663
02-19 12:39:17.129 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 3135CONTATO: Adan TELEFONE ORIGINAL: 01333116191 TELEFONE LIMPO: 1333116191
02-19 12:39:17.215 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 3134CONTATO: Adan TELEFONE ORIGINAL: 01397166702 TELEFONE LIMPO: 1397166702
02-19 12:39:17.301 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 3221CONTATO: Adriana Assis TELEFONE ORIGINAL: 0411193445311 TELEFONE LIMPO: 1193445311
02-19 12:39:17.361 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 3222CONTATO: Adriana Assis TELEFONE ORIGINAL: 1151891667 TELEFONE LIMPO: 1151891667
02-19 12:39:17.401 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 22966CONTATO: Adriana Schwartz TELEFONE ORIGINAL: +5511964968822 TELEFONE LIMPO: 11964968822
02-19 12:39:17.442 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 3146CONTATO: Adriana Trapp (ACE) TELEFONE ORIGINAL: 1150191034 TELEFONE LIMPO: 1150191034
02-19 12:39:17.460 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 3145CONTATO: Adriana Trapp (ACE) TELEFONE ORIGINAL: 0411199199138 TELEFONE LIMPO: 1199199138
02-19 12:39:17.478 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 22982CONTATO: Adriano Fernandes TELEFONE ORIGINAL: +5511995597192 TELEFONE LIMPO: 11995597192
02-19 12:39:17.490 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 1109CONTATO: Adriano Fernandes TELEFONE ORIGINAL: +551195597192 TELEFONE LIMPO: 1195597192
02-19 12:39:17.502 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 3965CONTATO: Adriano Fernandes TELEFONE ORIGINAL: +5511995597192 TELEFONE LIMPO: 11995597192
02-19 12:39:17.527 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 664CONTATO: Afonso obra TELEFONE ORIGINAL: 01186099135 TELEFONE LIMPO: 1186099135
02-19 12:39:17.560 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 4306CONTATO: Afonso obra TELEFONE ORIGINAL: 011986099135 TELEFONE LIMPO: 11986099135
02-19 12:39:17.596 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 32282CONTATO: Alan Martins TELEFONE ORIGINAL: +553133951732 TELEFONE LIMPO: 3133951732
02-19 12:39:17.614 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 15169CONTATO: Alan Martins TELEFONE ORIGINAL: +553175728232 TELEFONE LIMPO: 3175728232
02-19 12:39:17.633 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 10704CONTATO: Alberto Abubakir TELEFONE ORIGINAL: 07132453413 TELEFONE LIMPO: 7132453413
02-19 12:39:17.657 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 10705CONTATO: Alberto Abubakir TELEFONE ORIGINAL: 07134515531 TELEFONE LIMPO: 7134515531
02-19 12:39:17.686 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 23035CONTATO: Alberto Abubakir TELEFONE ORIGINAL: 07188459583 TELEFONE LIMPO: 7188459583
02-19 12:39:17.698 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 10706CONTATO: Alberto Abubakir TELEFONE ORIGINAL: 071988459583 TELEFONE LIMPO: 71988459583
02-19 12:39:17.718 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 4354CONTATO: Alberto Alberto Villaça Villaça TELEFONE ORIGINAL: 01121315010 TELEFONE LIMPO: 1121315010
02-19 12:39:17.743 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 4353CONTATO: Alberto Alberto Villaça Villaça TELEFONE ORIGINAL: 011983034499 TELEFONE LIMPO: 11983034499
02-19 12:39:17.781 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 23071CONTATO: Alberto Matos TELEFONE ORIGINAL: +557133587399 TELEFONE LIMPO: 7133587399
02-19 12:39:17.794 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 23072CONTATO: Alberto Matos TELEFONE ORIGINAL: +557134512182 TELEFONE LIMPO: 7134512182
02-19 12:39:17.806 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 23070CONTATO: Alberto Matos TELEFONE ORIGINAL: +557191599419 TELEFONE LIMPO: 7191599419
02-19 12:39:17.823 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 23073CONTATO: Alberto Matos TELEFONE ORIGINAL: +557199823924 TELEFONE LIMPO: 7199823924
02-19 12:39:17.836 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 7388CONTATO: Alberto Matos TELEFONE ORIGINAL: +557133587399 TELEFONE LIMPO: 7133587399
02-19 12:39:17.854 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 7387CONTATO: Alberto Matos TELEFONE ORIGINAL: +557134512182 TELEFONE LIMPO: 7134512182
02-19 12:39:17.876 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 7385CONTATO: Alberto Matos TELEFONE ORIGINAL: +557191599419 TELEFONE LIMPO: 7191599419
02-19 12:39:17.923 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 7386CONTATO: Alberto Matos TELEFONE ORIGINAL: +557199823924 TELEFONE LIMPO: 7199823924
02-19 12:39:17.991 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 13977CONTATO: Alberto Mimane TELEFONE ORIGINAL: 11999390213 TELEFONE LIMPO: 11999390213
02-19 12:39:18.098 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 4847CONTATO: Albinha TELEFONE ORIGINAL: +5511986452722 TELEFONE LIMPO: 11986452722
02-19 12:39:18.194 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 31698CONTATO: Alda Ferreira TELEFONE ORIGINAL: +5571987994206 TELEFONE LIMPO: 71987994206
02-19 12:39:18.256 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 3770CONTATO: Aldeia de Cambury TELEFONE ORIGINAL: 01238652138 TELEFONE LIMPO: 1238652138
02-19 12:39:18.335 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 4343CONTATO: Ale TELEFONE ORIGINAL: 011982990880 TELEFONE LIMPO: 11982990880
02-19 12:39:18.453 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 20857CONTATO: Alessandra Martins TELEFONE ORIGINAL: 011996118767 TELEFONE LIMPO: 11996118767
02-19 12:39:18.534 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 4805CONTATO: Alessandra Martins Machado Baggio TELEFONE ORIGINAL: 03121387154 TELEFONE LIMPO: 3121387154
02-19 12:39:18.599 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 3091CONTATO: Alessandro Nasser TELEFONE ORIGINAL: 01150542532 TELEFONE LIMPO: 1150542532
02-19 12:39:18.667 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 3093CONTATO: Alessandro Nasser TELEFONE ORIGINAL: 01151891323 TELEFONE LIMPO: 1151891323
02-19 12:39:18.737 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 3092CONTATO: Alessandro Nasser TELEFONE ORIGINAL: 01196533828 TELEFONE LIMPO: 1196533828
02-19 12:39:18.795 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 11852CONTATO: Alex Fabian Colares Silva TELEFONE ORIGINAL: 01130402644 TELEFONE LIMPO: 1130402644
02-19 12:39:18.895 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 11853CONTATO: Alex Fabian Colares Silva TELEFONE ORIGINAL: 01138468647 TELEFONE LIMPO: 1138468647
02-19 12:39:18.988 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 13474CONTATO: Alex Malchik TELEFONE ORIGINAL: +5511950268070 TELEFONE LIMPO: 11950268070
02-19 12:39:19.054 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 14436CONTATO: Alex Todres TELEFONE ORIGINAL: 551147609497 TELEFONE LIMPO: 1147609497
02-19 12:39:19.125 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 14435CONTATO: Alex Todres TELEFONE ORIGINAL: 5511983692223 TELEFONE LIMPO: 11983692223
02-19 12:39:19.198 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 4738CONTATO: Alex Tostes TELEFONE ORIGINAL: 01511988252180 TELEFONE LIMPO: 11988252180
02-19 12:39:19.260 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 4739CONTATO: Alex Tostes TELEFONE ORIGINAL: 01121752133 TELEFONE LIMPO: 1121752133
02-19 12:39:19.349 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 18943CONTATO: Alex Tostes TELEFONE ORIGINAL: 01511988252180 TELEFONE LIMPO: 11988252180
02-19 12:39:19.384 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 7095CONTATO: Alexandra TELEFONE ORIGINAL: 1176822827 TELEFONE LIMPO: 1176822827
02-19 12:39:19.450 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 8213CONTATO: Alexandra TELEFONE ORIGINAL: 11976822827 TELEFONE LIMPO: 11976822827
02-19 12:39:19.551 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 11919CONTATO: Alexandre Borges TELEFONE ORIGINAL: 1130495528 TELEFONE LIMPO: 1130495528
02-19 12:39:19.582 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 11918CONTATO: Alexandre Borges TELEFONE ORIGINAL: 1194441945 TELEFONE LIMPO: 1194441945
02-19 12:39:19.600 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 14577CONTATO: Alexandre Borges TELEFONE ORIGINAL: 11994441945 TELEFONE LIMPO: 11994441945
02-19 12:39:19.618 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 10601CONTATO: Alexandre Brito TELEFONE ORIGINAL: 01193902317 TELEFONE LIMPO: 1193902317
02-19 12:39:19.636 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 4877CONTATO: Alexandre Brito TELEFONE ORIGINAL: +5511993902317 TELEFONE LIMPO: 11993902317
02-19 12:39:19.671 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 2647CONTATO: Alexandre Cesar C. Alves TELEFONE ORIGINAL: 01135118843 TELEFONE LIMPO: 1135118843
02-19 12:39:19.707 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 2904CONTATO: Alexandre Cesar C. Alves TELEFONE ORIGINAL: 01185248218 TELEFONE LIMPO: 1185248218
02-19 12:39:19.725 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 3242CONTATO: Alexandre Cezar Suplicy Teixeira TELEFONE ORIGINAL: 01137677408 TELEFONE LIMPO: 1137677408
02-19 12:39:19.755 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 3241CONTATO: Alexandre Cezar Suplicy Teixeira TELEFONE ORIGINAL: 01199093057 TELEFONE LIMPO: 1199093057
02-19 12:39:19.767 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 8730CONTATO: Alexandre Cezar Suplicy Teixeira TELEFONE ORIGINAL: 011999093057 TELEFONE LIMPO: 11999093057
02-19 12:39:19.801 26903-27415/br.com.iuapp.iuapp D/ManageLocalContactsJob: RowId: 34430CONTATO: Alexandre Dias TELEFO...
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)