import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:https?|ftp)://)(?:\\S+(?::\\S*)?@)?(?:(?!10(?:\\.\\d{1,3}){3})(?!127(?:\\.\\d{1,3}){3})(?!169\\.254(?:\\.\\d{1,3}){2})(?!192\\.168(?:\\.\\d{1,3}){2})(?!172\\.(?:1[6-9]|2\\d|3[0-1])(?:\\.\\d{1,3}){2})(?:[1-9]\\d?|1\\d\\d|2[01]\\d|22[0-3])(?:\\.(?:1?\\d{1,2}|2[0-4]\\d|25[0-5])){2}(?:\\.(?:[1-9]\\d?|1\\d\\d|2[0-4]\\d|25[0-4]))|(?:(?:[a-z\\x{00a1}-\\x{ffff}0-9]+-?)*[a-z\\x{00a1}-\\x{ffff}0-9]+)(?:\\.(?:[a-z\\x{00a1}-\\x{ffff}0-9]+-?)*[a-z\\x{00a1}-\\x{ffff}0-9]+)*(?:\\.(?:[a-z\\x{00a1}-\\x{ffff}]{2,})))(?::\\d{2,5})?(?:/[^\\s]*)?$";
final String string = "Source regex above:\n"
+ "https://mathiasbynens.be/demo/url-regex\n\n\n"
+ "SHOULD MATCH:\n\n"
+ "http://foo.com/blah_blah\n"
+ "http://foo.com/blah_blah/\n"
+ "http://foo.com/blah_blah_(wikipedia)\n"
+ "http://foo.com/blah_blah_(wikipedia)_(again)\n"
+ "http://www.example.com/wpstyle/?p=364\n"
+ "https://www.example.com/foo/?bar=baz&inga=42&quux\n"
+ "http://✪df.ws/123\n"
+ "http://userid:password@example.com:8080\n"
+ "http://userid:password@example.com:8080/\n"
+ "http://userid@example.com\n"
+ "http://userid@example.com/\n"
+ "http://userid@example.com:8080\n"
+ "http://userid@example.com:8080/\n"
+ "http://userid:password@example.com\n"
+ "http://userid:password@example.com/\n"
+ "http://142.42.1.1/\n"
+ "http://142.42.1.1:8080/\n"
+ "http://➡.ws/䨹\n"
+ "http://⌘.ws\n"
+ "http://⌘.ws/\n"
+ "http://foo.com/blah_(wikipedia)#cite-1\n"
+ "http://foo.com/blah_(wikipedia)_blah#cite-1\n"
+ "http://foo.com/unicode_(✪)_in_parens\n"
+ "http://foo.com/(something)?after=parens\n"
+ "http://☺.damowmow.com/\n"
+ "http://code.google.com/events/#&product=browser\n"
+ "http://j.mp\n"
+ "ftp://foo.bar/baz\n"
+ "http://foo.bar/?q=Test%20URL-encoded%20stuff\n"
+ "http://مثال.إختبار\n"
+ "http://例子.测试\n"
+ "http://उदाहरण.परीक्षा\n"
+ "http://-.~_!$&'()*+,;=:%40:80%2f::::::@example.com\n"
+ "http://1337.net\n"
+ "http://a.b-c.de\n"
+ "http://223.255.255.254\n\n"
+ "SHOULD NOT MATCH:\n\n"
+ "http://\n"
+ "http://.\n"
+ "http://..\n"
+ "http://../\n"
+ "http://?\n"
+ "http://??\n"
+ "http://??/\n"
+ "http://#\n"
+ "http://##\n"
+ "http://##/\n"
+ "http://foo.bar?q=Spaces should be encoded\n"
+ "//\n"
+ "//a\n"
+ "///a\n"
+ "///\n"
+ "http:///a\n"
+ "foo.com\n"
+ "rdar://1234\n"
+ "h://test\n"
+ "http:// shouldfail.com\n"
+ ":// should fail\n"
+ "http://foo.bar/foo(bar)baz quux\n"
+ "ftps://foo.bar/\n"
+ "http://-error-.invalid/\n"
+ "http://a.b--c.de/\n"
+ "http://-a.b.co\n"
+ "http://a.b-.co\n"
+ "http://0.0.0.0\n"
+ "http://10.1.1.0\n"
+ "http://10.1.1.255\n"
+ "http://224.1.1.1\n"
+ "http://1.1.1.1.1\n"
+ "http://123.123.123\n"
+ "http://3628126748\n"
+ "http://.www.foo.bar/\n"
+ "http://www.foo.bar./\n"
+ "http://.www.foo.bar./\n"
+ "http://10.1.1.1\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.UNICODE_CASE | Pattern.DOTALL | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}