package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\w+=)?(\w+);`)
var str = `word2;word3
word1=word2;word3`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}