$re = '/(?:(?![a-zA-Z\d_])|\.|^)(iscord\.gift)(?:(?![a-zA-Z\d_.]))/m';
$str = 'discord.gift
cdn.discord.gift
iscord.gift
cdn.iscord.gift daw';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);