$re = '/^.*(require\(require\()(.+)(\);$)/';
$str = 'require(require(\'path\').resolve(path) + \'/node_modules/\' + file);';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);