$re = '/(?<=\[)[^\]\[]*?keyword[^\]\[]*(?=])/m';
$str = 'asdf asiodjfojewl kjwnkjwnefkjnkf [asdf] fasdfads fewrw [keyword<1] keyword [keyword>1]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);