$re = '/\d{6}[-+A]\d{3}[\dA-Z]/';
$str = '020692-237H';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);