import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(http|https)\\:\\/\\/(?:(.+?)(?:\\:(.+?))?\\@)?((?:[\\w-]+\\.)+)([A-Za-z0-9]+)(?:\\:(\\d{2,5}))?((?:\\/[\\w-%.]*)+)?(\\?(?:[\\w-%&=\"'+,]+)?)?(\\#(?:[^#]+)?)?";
final String string = "http://username:password@sub.domain.name:443/pathabc?query=\"abc\"#fragment";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}