$re = '/^[3569]\d{2}(?<!9{3})\d{5}$/m';
$str = '93214211
99912345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);