#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xis)^.*?\Kidr.?\s*[\d.,]+|" & @CRLF & _
".*?\Krp.?\s*[\d.,]+|" & @CRLF & _
".*?\Kprice\s*:?\s*[\d.,]+|" & @CRLF & _
".*?\K\s\d+\s?k\s|" & @CRLF & _
".*?\K\d+rb|" & @CRLF & _
".*?\K[0-9.,]+\s*ribu|" & @CRLF & _
".*?\K\b\d+[.,]\d+[.,]?\d+"
Local $sString = ""ABBY TOP" & @CRLF & _
" Colour : POLKA BLACK" & @CRLF & _
" Weight : 0,18" & @CRLF & _
" Price : 185,000" & @CRLF & _
" Material : Kaos Semi-Fleece" & @CRLF & _
" Size : Panjang / Length: 55 cm (depan), 72 (belakang)""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")