$re = '/[^\pL\pN.]+|\.(?![^.]+$)/mu';
$str = '#@.$cat.jpg';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;