const regex = new RegExp('[\\s\\S]{0,10}previously measured[\\s\\S]{0,10}|([0-4]\\.\\d+\\s*[mM]{2})[\\s\\S]{0,70}?[Nn]odule|[Nn]odule[\\s\\S]{0,70}?([0-4]\\.\\d+\\s*[mM]{2})', 'gs')
const str = `"For example, the largest nodule which is located in the right lower lobe and currently measures 4.4 mm (image #82, series 3) previously measured 3.6 mm on 09/01/2011."
"For example, the largest nodule which is located in the right lower lobe and currently measures 4.4 mm (image #82, series 3) previously measured 3.6 mm on 09/01/2011. Another nodule was found measuring 2.2 mm.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}