re = /(?!.*?\<<)string/i
str = 'string<< string string
string string<< string
string string string<<
string string string
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end