re = /(?=[-_a-zA-Z0-9]*?[A-Z])(?=[-_a-zA-Z0-9]*?[a-z])(?=[-_a-zA-Z0-9]*?[0-9])[-_a-zA-Z0-9]{6,}/m
str = 'Gjbs78tYU3'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end